Войти на сайт

или
Регистрация

Навигация


2. Используя Microsoft Excel, строим таблицы, приведённые на рис.2,3.

Для определения среднего бала экзаменационной сессии по курсам используем формулу для поиска среднего арифметического значения. Полученные значения заносятся в соответствующие ячейки таблицы 2. Для определения среднего бала экзаменационной сессии по факультетам действуем аналогично.

Чтобы округлить результат до одного десятичного знака после запятой, используем функцию ОКРУГЛ. Формат команды: ОКРУГЛ(А;В), где А – десятичное число; В – до какого знака необходимо округлить.

Используя округлённые значения среднего бала, определяем рейтинг каждого курса.

Вводим текущее значение даты между таблицей и её названием.

С помощью функции “мастер диаграмм” строим круговую диаграмму по данным таблицы (рис.3) называем её “ Средний балл по курсам”.

Далее приведено неформализованное решение задачи и инфологическая модель решения задачи.

Рис.4. Неформализованное решение задачи


Рис.5 Инфологическая модель решения задачи

3. Для выполнения практической работы выбираем программу Microsoft Excel, так как она полностью удовлетворяет всем потребностям. В Microsoft Excel организована работа с диаграммами, а также имеются необходимые встроенные функции.


Таблица 1.

Таблица с исходными данными

1 курс 2 курс 3 курс 4 курс 5 курс
балл Кол-во оценок балл Кол-во оценок балл Кол-во оценок балл Кол-во оценок балл Кол-во оценок
1 2 3 4 5 6 7 8 9 10
5 23 5 27 5 32 5 28 5 34
4 57 4 60 4 58 4 63 4 62
3 18 3 14 3 10 3 9 3 6
2 7 2 9 2 4 2 1 2
 
 курс средний балл рейтинг Средний балл Округл.
1 2 3 3,85981 3,9
1 3,9 5 3,92105 3,9
2 3,9 4 4,18182 4,2
3 4,2 3 4,37615 4,4
4 4,4 2 4,69643 4,7
5 4,7 1 Рис.3.Вспомогательная таблица.
по факультету 4,2
рис.2. Средний балл по курсам и факультету.

Средний бал по курсам

1—Средний балл по 1-му курсу.

2—Средний балл по 2-му курсу.

3-- Средний балл по 3-му курсу.

4-- Средний балл по 4-му курсу.

5-- Средний балл по 5-му курсу.


Курс Средний балл Рейтинг
1 2 3
1 =ОКРУГЛ((A3*B3+A4*B4+A5*B5+A6*B6+A7*B7)/B8;1)

ЕСЛИ(E12=НАИБОЛЬШИЙ(E12:E16;1);1;ЕСЛИ(E12=НАИБОЛЬШИЙ

(E12:E16;2);2;ЕСЛИ(E12=НАИБОЛЬШИЙ(E12:E16;3);3;

ЕСЛИ(E12=НАИБОЛЬШИЙ(E12:E16;4);4;5))))

2 =ОКРУГЛ((C3*D3+C4*D4+C5*D5+C6*D6+C7*D7)/114;1)

ЕСЛИ(E13=НАИБОЛЬШИЙ(E12:E16;1);1;ЕСЛИ(E13=НАИБОЛЬШИЙ

(E12:E16;2);2;ЕСЛИ(E13=НАИБОЛЬШИЙ(E12:E16;3);3;

ЕСЛИ(E13=НАИБОЛЬШИЙ(E12:E16;4);4;5))))

3 =ОКРУГЛ((E3*F3+E4*F4+E5*F5+E6*F6+E7*F7)/110;1) =ЕСЛИ(E14=НАИБОЛЬШИЙ(E12:E16;1);1;ЕСЛИ(E14=НАИБОЛЬШИЙ(E12:E16;2);2;ЕСЛИ(E14=НАИБОЛЬШИЙ(E12:E16;3);3;ЕСЛИ(E14=НАИБОЛЬШИЙ(E12:E16;4);4;5))))
4 =ОКРУГЛ((G3*H3+G4*H4+G5*H5+G6*H6+G7*H7)/109;1) =ЕСЛИ(E15=НАИБОЛЬШИЙ(E12:E16;1);1;ЕСЛИ(E15=НАИБОЛЬШИЙ(E12:E16;2);2;ЕСЛИ(E15=НАИБОЛЬШИЙ(E12:E16;3);3;ЕСЛИ(E15=НАИБОЛЬШИЙ(E12:E16;4);4;5))))
5 =ОКРУГЛ((I3*J3+I4*J4+I5*J5+I6*J6+I7*J7)/112;1) =ЕСЛИ(E16=НАИБОЛЬШИЙ(E12:E16;1);1;ЕСЛИ(E16=НАИБОЛЬШИЙ(E12:E16;2);2;ЕСЛИ(E16=НАИБОЛЬШИЙ(E12:E16;3);3;ЕСЛИ(E16=НАИБОЛЬШИЙ(E12:E16;4);4;5))))
По факультету =(B12+B13+B14+B15+B16)/5

Курс Средний балл Рейтинг
1 2 3
1 (1*2+5*23+4*57+3*18+2*7)/(2+23+57+18+7)=3,859813 5
2 (3*4+5*27+4*60+3*14+2*9)/(4+27+60+14+9)=3,92105 4
3 (5*6+5*32+4*58+3*10+2*4)/(6+32+58+10+4)=4,18182 3
4 (7*8+5*28+4*63+3*9+2*1)/(8+28+63+9+1)=4,37615 2
5 (9*10+5*34+4*62+3*6+2)/(10+34+62+6)=4,69643 1
По факультету 3,85981+3,92105+4,18182+4,37615+4,69643 = =4,207052

В практической части с использованием процессора MS Excel я рассчитала и представила в табличном виде согласно заданным формам результаты экзаменационной сессии с определением среднего балла по курсам и факультету и рейтинг успеваемости каждого курса.


6 Список литературы

1.   В.Ю. Демьяненко. “Программные средства создания и ведения баз данных”. – М.: Финансы и статистика, 1984.

2.   В.А. Мясников, С.А. Майоров, Г.И. Новиков. ЭВМ для всех. - М.: Знание, 1985.

3.   А.Г. Гейн. “Основы информатики и вычислительной техники”. - М.: Просвещение, 1997.

4.   В.Ф. Ляхович. “Основы информатики”.- Ростов-на-Дону: Феникс,1996.

5.   “Вычислительная техника и программирование”/Под ред. А.В. Петрова-М.: Высш. Шк.,1990.

6.         “Информационные технологии управления”: Инфоматика-М.Ф. Меняев: Омега-л, 2003.

7.   “Компьютерные системы и сети”/Под ред. В.П. Косарёва и Л.В. Ерёмина-М.: Финансы и статистика,1999.

8.   “Экономическая информатика”: Под ред. В.П. Косарёва и Л.В. Ерёмина-М.: Финансы статистика, 2001.

9.   “Информатика”: Под ред. Н.В. Макаровой: Фис., 1997

10.       “Информатика”, базовый курс , 2-е издание./ Под ред. С.В. Симоновича-СПб. Питер, 2004.

11.       Леонтьев: “ Новейшая энциклопедия программного компьютера”: Пресс,2003.

12.       Савинков В.М.”Толковый словарь по информатике”- 2-е издание,-М.: Финансы и статистика, 1995.

13.       “Вычислительные машины, системы и сети”/ Под ред. А.П. Пятибратова.-М.: Финансы и статистика, 1991.

14.       Якубайтис Э.А. “ Информационные сети и системы”. Справочная книга. - М.: Финансы и статистика, 1996.

15.       “Экономическая информатика и вычислительная техника”: Г.А. Титоренко, Н.Г. Черняк и др.; Под ред. В.П.Косарёва, А.Ю.Королёва.- 2-е издание, перераб. и доп.-М.: Финансы и статистика, 1996.

16.       Якубайтис Э.А.” Информатика – Электроника – Сети”. - М.: Финансы и статистика, 1984.

17.       “Персональный компьютер для всех”/ Под ред.А.Я. Савельева. - М.: Высшая школа,1991.

18.       “Информатика”. Энциклопедический словарь для начинающих. - М.: Пресс, 1994.

19.       Острейковский В.А.” Информатика”. - М.: Высшая школа,2000.

20.      Малютин Э.А., Малютина Л.В. Языки программирования, 1982 г

21. Ваулин А.С. Языки программирования.— кн.5, 1993 г.;


[1] Самоучитель программирования.

[2] Леонтьев. Новейшая энциклопедия программного компьютера. — Пресс,2003.

[3] Острейковский В.А. Информатика. — М.: Высшая школа,2000

[4] М.Ф. Меняев. Информационные технологии управления.— Омега-л, 2003

[5] Вычислительные машины, системы и сети — Под ред. А.П. Пятибратова.-М.: Финансы и статистика, 1991).

[6] Якубайтис Э.А. Информационные сети и системы. Справочная книга.— М.: Финансы и статистика, 1996

[7] Савинков В.М. Толковый словарь по информатике.— 2-е издание,-М.: Финансы и статистика, 1995

[8] Информатика, базовый курс , 2-е издание./ Под ред. С.В. Симоновича-СПб. Питер, 2004

[9] Экономическая информатика.— Под ред. В.П. Косарёва и Л.В. Ерёмина-М.: Финансы статистика, 2001

[10] Персональный компьютер для всех.— Под ред.А.Я. Савельева. - М.: Высшая школа,1991

[11] В.Ф. Ляхович. Основы информатики.— Ростов-на-Дону: Феникс,1996


Информация о работе «Языки программирования»
Раздел: Информатика, программирование
Количество знаков с пробелами: 37109
Количество таблиц: 5
Количество изображений: 4

Похожие работы

Скачать
48658
0
0

... времени на возню с файлами на дисках или ожидание ввода, не смогут продемонстрировать какое-то впечатляющее увеличение скорости. 2. КЛАССИФИКАЦИЯ ЯЗЫКОВ ПРОГРАММИРОВАНИЯ 2.1. Машинно – ориентированные языки  Машинно – ориентированные языки – это языки, наборы операторов и изобразительные средства которых существенно зависят от особенностей ЭВМ (внутреннего языка, структуры памяти и ...

Скачать
41510
0
0

... . Например, не существует типа матрица с операцией обращения или типа строка с операцией конкатенации. Если пользователю понадобятся подобные типы, он может определить их в самом языке. Программирование на С++ по сути сводится к определению универсальных или зависящих от области приложения типов. Хорошо продуманный пользовательский тип отличается от встроенного типа только способом определения, но ...

Скачать
23064
0
0

... программ, которые применяются для передачи компьютеру инструкций по выполнению того или иного вычислительного процесса и организации управления отдельными устройствами. Задача: язык программирования отличается от естественных языков тем, что предназначен для передачи команд и данных от человека компьютеру, в то время как естественные языки используются лишь для общения людей между ...

Скачать
44688
14
5

... . И хотя, используя недокументированные возможности и определённые ухищрения, всё это можно реализовать и на VB; пользоваться этими трюками гораздо сложнее, чем, например, на Delphi. 4. ПРАКТИЧЕСКАЯ РЕАЛИЗАЦИЯ ЗАДАЧ С ИСПОЛЬЗОВАНИЕМ ЯЗЫКА ПРОГРАММИРОВАНИЯ DELPHI   4.1 Задача 1. Примитивный калькулятор   1. Войдите в среду Delphi, дважды щелкнув мышью на пиктограмму Delphi или через меню “ ...

0 комментариев


Наверх